Strata Networks - Cellular Outage – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Language
All systems operational
Cellular Outage
Resolved
Outage
Started 6 days ago
Lasted about 3 hours
Affected
Cellular
Outage from 7:15 PM to 9:55 PM
Updates
Resolved
06 22nd 2026 at 9:55 PM
Resolved
06 22nd 2026 at 9:55 PM
The Cellular Outage has been Resolved.
Investigating
06 22nd 2026 at 7:15 PM
Investigating
06 22nd 2026 at 7:15 PM
There is an outage affecting cellular devices. If you would like to speak to a Cellular Technician about your cellular service please contact STRATA Networks at 435-622-5007.