Strata Networks - Broadband Outage – Incident details

All systems operational

Broadband Outage

Resolved
Outage
Started 4 months agoLasted about 5 hours

Affected

Internet

Outage from 4:07 PM to 9:07 PM, Operational from 9:07 PM to 9:07 PM

Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting the Utah and Colorado area(s). If you are not in the Utah and Colorado area(s) or your internet has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.