Operational from 12:42 AM to 12:42 AM, Partial outage from 12:42 AM to 2:51 AM
Updates
Resolved
Resolved
The partial outage affecting the Vernal area(s) has been resolved. Services have been restored.
Investigating
Investigating
There is a partial outage in the Vernal area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.