Experiencing minor outage

Cellular Outage

Resolved
Outage
Started about 1 month ago Lasted about 3 hours

Affected

Cellular
Updates
  • Resolved
    Resolved

    The Cellular Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting cellular devices. If you would like to speak to a Cellular Technician about your cellular service please contact STRATA Networks at 435-622-5007.