Experiencing minor outage

Broadband Outage

Resolved
Outage
Started 2 months ago Lasted about 13 hours

Affected

Internet
Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting the FWA in the Basin area(s). If you are not in the FWA in the Basin area(s) or your internet has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.