All systems operational

Resolved
Broadband Outage

Started
23rd 05 2023 at 9:03 PM
Status
Resolved after about 1 hour

Impact

Major outage
Affected
Internet
  • Resolved

    The Broadband Outage has been Resolved.

  • Investigating

    There is an outage affecting the Email area(s). If you are not in the Email area(s) or your internet has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.