All systems operational

Broadband Outage

Resolved
Partial outage
Started 6 days ago Lasted about 3 hours

Affected

Internet
Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Investigating
    Investigating

    There is a partial outage in the Ballard area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.