All systems operational

Tabiona Fiber Network Maintenance

Completed
Scheduled for 04 10th 2024 at 5:59 AM – 10:59 AM

Affects

Internet
Landline
Updates
  • Completed
    04 10th 2024 at 10:59 AM
    Completed
    04 10th 2024 at 10:59 AM
    Maintenance has completed successfully
  • In progress
    04 10th 2024 at 5:59 AM
    In progress
    04 10th 2024 at 5:59 AM
    Maintenance is now in progress
  • Planned
    04 10th 2024 at 5:59 AM
    Planned
    04 10th 2024 at 5:59 AM

    Scheduled maintenance on the fiber network in the Tabiona is set to begin at 11:59 P.M. on April 9th and is expected to be completed by 4:59 A.M. on April 10th. During this period, broadband services in Tabiona may be affected. We thank you for your patience as we make network improvements in this area.