Started over 1 year ago03 25th 2025Lasted about 5 hours03 25th 202510:44 PM03 26th 20253:32 AMUTC
Affected
Internet
Partial outage from 10:44 PM to 3:32 AM, Operational from 3:32 AM to 3:32 AM
Updates
Resolved
UTC
Resolved
UTC
The Broadband Outage has been Resolved.
Investigating
UTC
Investigating
UTC
There is a partial outage in the Strawberry area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.