Started over 1 year ago03 16th 2025Lasted about 7 hours03 16th 202511:33 AM6:58 PMUTC
Affected
Cellular
Outage from 11:33 AM to 6:58 PM
Updates
Resolved
UTC
Resolved
UTC
Service has been fully restored. Thank you for your patience.
Update
UTC
Update
UTC
The cause has been identified, and our technicians are actively working to restore service.
Identified
UTC
Identified
UTC
Our wireless technicians are actively working to resolve the issue. We appreciate your patience as they continue their efforts to restore service.
Investigating
UTC
Investigating
UTC
There is an outage affecting cellular devices. If you would like to speak to a Cellular Technician about your cellular service please contact STRATA Networks at 435-622-5007.