Scheduled for 03 5th 2025 at 6:00 AM – 11:00 AM
Affects
Internet
Under maintenance from 6:00 AM to 11:00 AM
Cellular
Under maintenance from 6:00 AM to 11:00 AM
Completed
03 5th 2025 at 11:00 AMCompleted
03 5th 2025 at 11:00 AMMaintenance has completed successfully
In progress
03 5th 2025 at 6:00 AMIn progress
03 5th 2025 at 6:00 AMMaintenance is now in progress
Planned
03 5th 2025 at 6:00 AMPlanned
03 5th 2025 at 6:00 AMWe will be performing maintenance in the Vernal area, which will impact broadband and cellular services in some areas of Vernal. This work is essential to ensure the continued reliability and performance of our network. We appreciate your patience and understanding as we carry out this maintenance to keep the network running optimally.