Strata Networks - Broadband Outage – Incident details

Internet experiencing partial outage

Broadband Outage

Resolved
Outage
Started about 2 months agoLasted about 15 hours

Affected

Internet

Operational from 9:18 PM to 9:18 PM, Outage from 9:18 PM to 11:50 AM, Operational from 11:50 AM to 11:50 AM

Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting the Ballard area(s). If you are not in the Ballard area(s) or your internet has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.