Strata Networks - Broadband Outage – Incident details

All systems operational

Broadband Outage

Resolved
Outage
Started 19 days agoLasted about 10 hours

Affected

Internet

Outage from 11:20 AM to 9:16 PM, Operational from 9:16 PM to 9:16 PM

Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting the Maser area(s). If you are not in the Maser area(s) or your internet has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.