Operational from 1:22 AM to 1:22 AM, Partial outage from 1:22 AM to 2:15 AM, Operational from 2:15 AM to 2:15 AM
Updates
Resolved
Resolved
The Broadband Outage has been Resolved.
Investigating
Investigating
There is a partial outage in the Vernal area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.