Operational from 4:07 PM to 4:07 PM, Partial outage from 4:07 PM to 3:35 PM, Operational from 3:35 PM to 3:35 PM
Updates
Resolved
Resolved
The Broadband Outage has been Resolved.
Investigating
Investigating
There is a partial outage in the Naples area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.