Strata Networks - Broadband Degraded Performance – Incident details

All systems operational

Broadband Degraded Performance

Resolved
Degraded performance
Started 23 days agoLasted about 23 hours

Affected

Internet

Degraded performance from 11:19 PM to 9:58 PM, Operational from 9:58 PM to 9:58 PM

Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Identified
    Identified

    Our technicians have identified a service degradation issue in the Painted Hills area of Maeser and are working diligently to address the issue. Service is online, but some locations have experienced service related issues. We will provide further updates as more information becomes available. We appreciate your patience as we work to resolve this issue.

  • Investigating
    Investigating

    There is a partial outage in the Painted Hills, Maeser area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.