Operational from 8:30 PM to 8:30 PM, Partial outage from 8:30 PM to 9:26 PM, Operational from 9:26 PM to 9:26 PM
Updates
Resolved
Resolved
The Broadband Outage has been Resolved.
Investigating
Investigating
There is a partial outage in the Vernal area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.