Strata Networks - Landline Outage – Incident details

Internet under maintenance

Landline Outage

Resolved
Partial outage
Started 2 months agoLasted about 5 hours

Affected

Landline

Operational from 5:42 PM to 5:42 PM, Partial outage from 5:42 PM to 10:36 PM, Operational from 10:36 PM to 10:36 PM

Updates
  • Resolved
    Resolved

    The Landline Outage has been Resolved.

  • Investigating
    Investigating

    There is a partial outage in the Whiterocks area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.