Operational from 5:42 PM to 5:42 PM, Partial outage from 5:42 PM to 10:36 PM, Operational from 10:36 PM to 10:36 PM
Updates
Resolved
Resolved
The Broadband Outage has been Resolved.
Investigating
Investigating
There is a partial outage in the Whiterocks area(s), please contact the Network Operations Center at 435-622-5151 to verify you are affected by the outage.