Operational from 2:43 AM to 2:43 AM, Outage from 2:43 AM to 3:07 AM, Operational from 3:07 AM to 3:07 AM
Updates
Resolved
Resolved
The Cellular Outage has been Resolved.
Investigating
Investigating
There is an outage affecting cellular devices. If you would like to speak to a Cellular Technician about your cellular service please contact STRATA Networks at 435-622-5007.