Scheduled for 05 6th 2024 at 5:00 AM – 12:30 PM
Affects
Cellular
Under maintenance from 5:00 AM to 12:30 PM
- Completed 05 6th 2024 at 12:30 PM
- Completed - 05 6th 2024 at 12:30 PM- Maintenance has completed successfully 
 
- In progress 05 6th 2024 at 5:00 AM
- In progress - 05 6th 2024 at 5:00 AM- Maintenance is now in progress 
 
- Planned 05 6th 2024 at 5:00 AM
- Planned - 05 6th 2024 at 5:00 AM- Maintenance is planned for May 5th, 11PM to May 6th, 6:30AM that may impact cellular services. We apologize for any inconvenience.