Scheduled for 04 10th 2024 at 5:55 AM – 6:55 AM
Affects
Landline
Under maintenance from 5:55 AM to 6:55 AM
Completed
04 10th 2024 at 6:55 AMCompleted
04 10th 2024 at 6:55 AMMaintenance has completed successfully
In progress
04 10th 2024 at 5:55 AMIn progress
04 10th 2024 at 5:55 AMMaintenance is now in progress
Planned
04 10th 2024 at 5:55 AMPlanned
04 10th 2024 at 5:55 AMScheduled maintenance on the HPBX system is set to begin at 11:55 P.M. on April 9th and is expected to be completed by 1 A.M. on April 10th. During this period, HPBX services will be affected. We thank you for your patience as we make network improvements.