All systems operational

Broadband Outage

Resolved
Major outage
Started over 1 year ago Lasted 39 minutes

Affected

Internet
Updates
  • Resolved
    Resolved

    The Broadband Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting the Duchesne area(s). If you are not in the Duchesne area(s) or your internet has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.