All systems operational

Landline Outage

Resolved
Major outage
Started over 1 year ago Lasted about 1 hour

Affected

Landline
Updates
  • Resolved
    Resolved

    The Landline Outage has been Resolved.

  • Investigating
    Investigating

    There is an outage affecting the Roosevelt area(s). If you are not in the Roosevelt area(s) or your landline has been offline for longer than 1 hour, please get in touch with the Network Operations Center at (435) 622-5151.