All systems operational

Emergency Maintenance Notification

Completed
Scheduled for 10 27th 2022 at 2:00 PM – 11:00 PM

Affects

Internet
Landline
Updates
  • Completed
    10 27th 2022 at 11:00 PM
    Completed
    10 27th 2022 at 11:00 PM

    Maintenance has completed successfully

  • In progress
    10 27th 2022 at 2:00 PM
    In progress
    10 27th 2022 at 2:00 PM

    Maintenance is now in progress

  • Planned
    10 27th 2022 at 2:00 PM
    Planned
    10 27th 2022 at 2:00 PM

    STRATA Networks will repair a section of fiber in the Hanna area. The affected service areas will be north of Hanna, Stockmore, Cripple Creek, and Rock Creek. Broadband internet and voice services will experience service disruptions during this maintenance window.

    If you have any issues or questions regarding this maintenance, please contact customer support anytime 24/7 at 435-622-5007.