All systems operational

Uintah Basin Maintenance

Completed
Scheduled for 10 26th 2022 at 5:59 AM – 10:00 AM

Affects

Internet
Updates
  • Completed
    10 26th 2022 at 10:00 AM
    Completed
    10 26th 2022 at 10:00 AM

    Maintenance has completed successfully

  • In progress
    10 26th 2022 at 5:59 AM
    In progress
    10 26th 2022 at 5:59 AM

    Maintenance is now in progress

  • Planned
    10 26th 2022 at 5:59 AM
    Planned
    10 26th 2022 at 5:59 AM

    Internet services in Vernal, Roosevelt, and Duchesne will undergo planned maintenance from October 25th at 11:59 PM to at 4:00 AM. Broadband internet will experience service disruptions during this maintenance window.

    If you have any issues or questions regarding this maintenance, please contact customer support anytime 24/7 at 435-622-5007.