All systems operational

Providence Maintenance Notification

Completed
Scheduled for 09 28th 2022 at 6:01 AM – 8:01 AM

Affects

Internet
Updates
  • Completed
    09 28th 2022 at 8:01 AM
    Completed
    09 28th 2022 at 8:01 AM

    Maintenance has completed successfully

  • In progress
    09 28th 2022 at 6:01 AM
    In progress
    09 28th 2022 at 6:01 AM

    Maintenance is now in progress

  • Planned
    09 28th 2022 at 6:01 AM
    Planned
    09 28th 2022 at 6:01 AM

    Providence City fiber optic network customers will experience an interruption to their service of approximately 10 minutes at any time during the maintenance window.