All systems operational

Landline and Cellular Outage

Resolved
Major outage
Started over 1 year ago Lasted about 4 hours

Affected

Landline
Cellular
Updates
  • Resolved
    Resolved

    All services affected by this outage should be restored at this time. If you are still experiencing service interruptions, please contact our 24/7 Technical Support team at (435) 622-5007.

  • Investigating
    Investigating

    We are aware of an issue effecting some wireless roaming and landline calls that has arisen due to the power outage yesterday. Our technicians are investigating the issue and we appreciate your patience as they work to restore full service.