All systems operational

Cellular Outage

Resolved
Major outage
Started over 1 year ago Lasted about 1 hour

Affected

Cellular
Updates
  • Resolved
    Resolved

    The Major Cellular Outage has been Resolved.

  • Investigating
    Investigating

    There is a Major Outage affecting some Cellular Customers