All systems operational

Resolved
Broadband Outage

Started
July 29, 2022 at 2:11 PM
Status
Resolved after about 1 hour
Affected
Internet

Impact

Major outage
  • Resolved
    July 29, 2022 at 3:32 PM

    The Major Broadband Outage has been Resolved.

  • Investigating
    July 29, 2022 at 2:11 PM

    There is a Major Outage affecting some Broadband Customers